Page 3 of 5

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Thu May 31, 2018 9:33 pm
by Shaneee
AlGrey wrote:0x043bb1022
Shouldn't it be 0x43bb1022? Same ID as mine.

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Thu May 31, 2018 10:37 pm
by AlGrey
Shaneee wrote:
AlGrey wrote:0x043bb1022
Shouldn't it be 0x43bb1022? Same ID as mine.
Indeed, I have no idea why the zero is there but it still works :P

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Sat Jun 02, 2018 9:38 am
by JohnSmith
Norton287 wrote:
JohnSmith wrote: Wed May 30, 2018 5:08 pm Thanks for that, but unfortunately it is only showing me a generic "(null) (Handle: 0xD) connection failed, status: 0x04". Personal Hotspot on my iPhone and bluetooth speakers are fine. I think it might be the kext. I'm going to keep trying to investigate.
Ok
Just a quick update to this, the verbose output is showing that it can't load 'com.apple.driver.IOBluetoothHIDDriver' and com.apple.driver.AppleHSBluetoothDriver'. It is just HID devices that I'm having trouble with.

It would be nice to know what the fix actually does. My card (and dongle) are both natively supported in macOS.

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Sat Jun 02, 2018 11:46 am
by Norton287
Try the 10.12.6 fixes. Some have had success with them.

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Tue Jun 05, 2018 11:54 am
by JohnSmith
Norton287 wrote:Try the 10.12.6 fixes. Some have had success with them.
I did try this before (and I just tried again), with that I don't get any Bluetooth at all. The fix in the first post is the only thing that gets me Bluetooth.

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Tue Jun 05, 2018 2:07 pm
by Norton287
Ok let's see what a new GenericUSBXHCI.kext will do. Shaneee is collecting updated info from people towards that.

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Tue Jun 05, 2018 3:21 pm
by JohnSmith
Norton287 wrote:Ok let's see what a new GenericUSBXHCI.kext will do. Shaneee is collecting updated info from people towards that.
Yeah, I saw this! I have posted a screenshot over on that post. Is the idea to use a new GenericUSBXHCI.kext + the fix or just the kext by itself?

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Tue Jun 05, 2018 3:56 pm
by Norton287
hopefully the kext itself should resolve some of the bluetooth issues

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Thu Jun 07, 2018 10:51 am
by JohnSmith
Norton287 wrote:hopefully the kext itself should resolve some of the bluetooth issues
Fantastic, I really appreciate your help! Thank you.
Post Merged
AlGrey wrote: Wed Jan 24, 2018 10:46 pm What is even better.. GenericUSBXHCI.kext for the Chipset controller (id 0x43bb1022) and native support for the 4 USB ports controlled by the CPU. My BT dongle is working OOB now using a CPU controlled USB port.
I gave this a go with 0x43D01022 ... and it didn't change the Bluetooth situation at all :-( ... any advice?

Re: Bluetooth fix for Ryzen Procs and macOS 10.13.x

Posted: Sat Jun 09, 2018 4:17 pm
by AlGrey
@JohnSmith, try all your USB ports. Also revert to stock files if you applied the fix by Norton. You can also save and send me your IOreg :