Page 11 of 15

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Thu Mar 01, 2018 2:20 am
by AlGrey
Here is what you can try in your config :
1. Remove -radvesa or -radoff. No inject ATi, no RadDeInit. use fake ID 0x67411002. In bios : CSM on, Serial IO always off. Keep Whatevergreen + lilu in /EFI/Clover/Kexts/xxxx (Other or 10.13).
2.A ) Add -radoff, RadDeInit, use fake ID 0x67411002. In bios : CSM disabled, Serial IO always off.
B) like A but add FB name = Cattail, and Set InjectATI

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Thu Mar 01, 2018 3:34 pm
by Mustafa Salim
Here is the result of the testing:
1. Boot successful, but vga memory just 7mb
2. A) Boot successful, but vga memory just 7mb
B) Monitor lost connection after early boot

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Sat Mar 03, 2018 7:43 pm
by AlGrey
The solution for that card is to add the ID (0x67421002) manually to the controllers and change colors with SwitchResX to millions to fix flickering.

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Sun Mar 04, 2018 12:37 am
by Mustafa Salim
Works like a charm, thank you :thumbup: :D

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Sun Mar 11, 2018 6:48 pm
by AlGrey
Sapphire Vapor-X R9 280X 3G D5 patch for DVI in 10.13

FB Name : Namako
INJECT ATI : TRUE
RADEONDEINIT : checked
New KextsToPatch entry (Name / Find / Replace / comment ...):
Code: Select all
NAME : AMD7000Controller

FIND
020000000001000000010151000000002205020200000000
020000000001000000010261010000001204010100000000
000400000403000000010343000000001102030300000000
000400000403000000010433000000002103040400000000

REPLACE
000800000402000000010000000000002205050400000000
040000001400000000010000000000001102010300000000
000400000403000000010000000000001204060100000000
040000001402000000010000000000000000030600000000

COMMENT : Asus vapor-x 280x

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Tue Mar 13, 2018 2:11 pm
by sebasrock156
The ID from my GPU is 0x9874, I don't understand the explain for make a "fake" GPU Kext.

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Tue Mar 13, 2018 7:03 pm
by AlGrey
@sebasrock156, your iGPU are not supported

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Wed Mar 14, 2018 1:57 am
by sebasrock156
AlGrey wrote:@sebasrock156, your iGPU are not supported
I know...

Some way for "Emulate" it?

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Wed Mar 14, 2018 1:58 am
by AlGrey
No you can only boot with -radvesa as a custom boot args.
Post Merged
In clover at boot -> OPTIONS -> bootargs. Add
Code: Select all
-radvesa
Make sure -radoff is not set as a boot argument. Delete it if there.

Then open your EFI folder with clover configurator, open config.plist and add the argument to the custom Flags under the BOOT tab. Make sure -radoff is not set as a boot argument. Delete it if there.

Save and reboot

Re: FIX ATI/AMD GRAPHIC GLITCHES [with working/bootable hackintosh ONLY]

Posted: Tue Jun 26, 2018 8:21 pm
by AlGrey
For records, fix for the XFX R9 270X is :

injectATI + fb= FUTOMAKI + load vbios +
Code: Select all
https://www.techpowerup.com/vgabios/163550/his-r9270x-2048-131212-1
in /EFI/CLOVER/ROM as 1002_6810.rom