Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: dankesweed
#25063
Shaneee wrote:Remove the AMD kexts relating to your GPU and run the post install again to rebuild the prelinkedkernel. This will of course cause no GPU acceleration but we'll sort that. If it boots I'll source kexts it should work with. I just need to know the kexts your GPU uses.
removed AMD9000Controller.kext which should be the one for r9 380x (looked up on
Code: Select all
 https://www.tonymacx86.com/threads/radeon-compatibility-guide-ati-amd-graphics-cards.171291/
and rebuild the prelinkedkernel. same results :/

 Advertising

User avatar
by: Shaneee
#25064
You'll need to remove the X4000 kext too. Alternatively try with SierraAMD V4 rather than V4.5. V4 was 10.12.4 or 10.12.5 I can't remember,
Code: Select all
http://52.232.81.87/AMDOSX/Sierra/SierraAMD%204/
User avatar
by: dankesweed
#25067
Shaneee wrote:You'll need to remove the X4000 kext too. Alternatively try with SierraAMD V4 rather than V4.5. V4 was 10.12.4 or 10.12.5 I can't remember,
Code: Select all
http://52.232.81.87/AMDOSX/Sierra/SierraAMD%204/
that url doesn't work? deleted x4000 too, no change.
User avatar
by: suyash
#25092
will this work for intel hd 5500u?
User avatar
by: Shaneee
#25135
@dankesweed, Here's a link for V4,
Code: Select all
https://mega.nz/#!IGxHlLQZ!SECzd3jocLe0BWRD-Aq_dlKMAkNRoY6cS-8VKwkDr00
@suyash, For Intel you are best to make the USB with createinstallmedia and use Clover.
User avatar
by: CookieKingHK
#25225
AmoryYugen wrote: Sat Aug 05, 2017 7:10 pm
CookieKingHK wrote:Solved. I have reinstalled the system. And when installing Clover, I checked the Driver64-nvme Then I reboot my machine from disk, and add all the patches for nvme---sierra from Clover patchlist. Identified well,trying to move my system to SSD.
Can you walk a noob through this process, specifically with 10.12.6? I just put together my first Hackintosh and created the bootable USB according to the tutorial. After awhile it finally got the OS X installation, but predictably could not find a suitable HD as I've only got a Samsung Evo 960 installed at the moment. Will be receiving a 2.5" Samsung SSD later this week, which I suppose will be an easier install.

EDIT: I successfully installed OS X on an external HD. It's not bootable from anything but the USB drive, but I assume that's typical. Once my non-NVMe SSD arrives on Monday, I'll move put the OS on there. Let me know if you have success using the NVMe as your boot drive... I'd love to know how you accomplished this!
Yes, I have installed with success in my NVME SSD. And I am to take steps to tell you how.
1) Install Hackintosh in HDD which you have done.
But something like you did not install Clover successfully. Or check in BIOS, if you selected HDD as the primary boot device.
2) Copy the system to new SSD.
Boot to your system. (If you have fixed the first problem, this would be not that painful)
Must for NVME device: Use patches to let the system to detect 3-rd party NVME device. In Clover, Kernel and Kext Patches section. Add 17 for Sierra. Another patch which seems like a leader(?) with check Inforplistpatch. Then reboot. And you can open Disk Utility, NVME device is there.
Here, not AD, I use Carbon Copy Cloner. Copy your partition to new SSD. When it done, then, download latest Clover and install it to the new device. And you can copy or edit the default config.plist of new.
Shutdown
3) Boot into BIOS
Make the new device as the primary boot device. Save and shutdown,
Obv, try UEF first
4) Done? Enjoy it
User avatar
by: Musikalmonk
#25276
Sorry guys, new to forums and have been posting in the wrong place. I've followed the instructions, installed and configured clover as in the videos. But it still won't boot from the hdd. The screen is also glitchy and the icons are messed up. Apart from that, everything is great. Any help would be appreciated. My hdd isn't displayed in the lower screen in clover vibrant either, but I don't think it's meant to be visible yet, right?
Thanks guys

Edit---------
Amd fx 8350
16GB Samsung ram
2tb seagate Barra (green) hdd (1.5tb Mac)
GeForce gt240
User avatar
by: pouryaaaa
#25291
hi
something is wrong with my hackintosh , i want to login to my apple id and apple said that you device not recognise as a selling device and i google it and they gave me solution that i must set my builtin Ethernet to en0 but after i install this in my network preference i dont have any Ethernet device ! my mainboard is asus fx990 pro r2 and i install the kext rtl8111 release version and rebuild permission and cache but same as my clone install no effect has happened anyone have any solution ?
User avatar
by: Shaneee
#25337
@Musikalmonk, Upload your config.plist file for Clover.

@pouryaaaa, See this post, viewtopic.php?f=24&t=947
User avatar
by: Musikalmonk
#25369
@Shaneee the one from the USB(sierra amd) efi? I can't mount my macOS efi
-edit-
my bad, i was trying to boot with a partitioned hdd. All good now, i think i just need to download nvidia drivers (i think) it seems to restart when it's looking for the pci driver. will upload config if it doesn't work.
thanks
-edit-
ok i've dwnloaded the nvidia driver WebDriver-378.05.05.25f01 but still not booting from hdd.
here's the config file... sorry only let me add it if i zipped it
Attachments
(3.97 KiB) Downloaded 30 times
  • 1
  • 23
  • 24
  • 25
  • 26
  • 27
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]