Welcome to AMD OS X

Why not register now to gain full access.

Development and testing of modified XNU Kernels for AMD CPUs on OS X
#43457
I am trying to get into direct kernel modding (instead of kexts) but I have been running into this error over and over again on multiple machines. When I invalidate kextcache I get a long list of missing symbols (to be expected) then
Code: Select all
Can't use IONetworkingFamily.kext - not linked.
Prelink failed for com.apple.driver.mDNSOffloadUserClient; aborting prelink.
Every time on all 10.13.6 set ups I have tried.

I am trying to build this on real Apple hardware and I've asked around but no one seems to know what is wrong. I hope it is okay to ask you all because it seems like the Hackintosh community are the only people out here who really understand XNU (besides the folks at PureDarwin). I'd like to get this built in an "expected" environment before jumping onto other platforms.

If anyone knows what I can do to get a 10.13.6 kernel linked, please let me know. I have tried on 2 different MBPs, a few different VMs, and one hackintosh. Same error every time.

 Advertising

#43458
See here, https://github.com/AMD-OSX/High-Sierra- ... 1fab149cac

Apple didn't add the function in the release.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]