Welcome to AMD OS X

Why not register now to gain full access.

Development and testing of modified XNU Kernels for AMD CPUs on OS X
User avatar
by: pink101
#33641
What do i mean by 'AMD kernel buggy'? well... here's my story...
FIrst of all, i'm not a programmer, but i'm really curious on installing osx on my AMD machine. So the first step to installing OSX on AMD is creating an installer. I did that and success on making it (the installer). Then After that, we install it on the hard drive. Now this is where i found it challenging. The short version of my experience is that i finally success installing OSX Yosemite 10.10.0 on my 16GB microSD card. It can boot and everything. After that, using disk utility i make dmg image of the system, then i transfer my system to my old 20GB IDE hardisk using IDEtoUSB converter. After that I boot my Yosemite using my old 20GB drive from USB. Now this is the buggy part... It can boot like the one on microSD, but after +/- 3 second it then hang with spinning ball, but that's not what bug me, the problem is that when i restart the system, the hfsplus partition become corrupt and cannot be fixed by disk utility. I tried it many times with both 10.10.0 and 10.10.5 with many different kernels and the partition is always corrupt after hang. Why i suspect that it was the AMD kernel? Because when i tried it on intel machine, not only that my old 20GB disk can boot successfully, but also when i hit reset on my intel machine, the partition didn't become corrupt like it was on my AMD machine.
I'm curious if anybody have the same experience as i do? btw, here's post about my AMD system

PS: To admin, if this is the wrong section to post this topic please move it to the right section, thank you...

 Advertising

User avatar
by: Norton287
#33647
Its because you're using IDE, the drive needs to be set to AHCI
User avatar
by: pink101
#33680
Norton287 wrote:Its because you're using IDE, the drive needs to be set to AHCI
Not really... im using my IDE drive through a USB converter, and if that's really the reason, then why on Intel system the hardisk work just fine?
User avatar
by: Norton287
#33685
This is amd not intel
Egress liked this
User avatar
by: pink101
#34216
Just bought IDE to sata converter, now the problem no longer exist.... i can still use my IDE hardisk as a test drive for Hackintosh and both hang problem and partition corrupt problem seems no longer exist...
Papa John liked this
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]